#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(NAME)((\s)?:(\s)?)([ |,| (|)|\\|\.|\"|\w|\-|\+]*)((\s)*?,(\s)*?)(DESCR)((\s)?:(\s)?)([ |,| (|)|\\|\.|\"|\w|\-|\+]*)(\s)(PID)((\s)?:(\s)?)([\w|\-|\+|=]+)((\s)+,(\s)+)(VID)((\s)?:(\s)?)([\w| ]*)((\s)+,(\s)+)(SN)((\s)?:(\s)?)([\w| ]*)"
Local $sString = "WDL3-4N-C4510-1A#show inventory" & @CRLF & _
"NAME: "Switch System", DESCR: "Cisco Systems, Inc. WS-C4510R+E 10 slot switch "" & @CRLF & _
"PID: WS-C4510R+E , VID: V03 , SN: FOX1616GNS8" & @CRLF & _
"" & @CRLF & _
"NAME: "Clock Module", DESCR: "Clock Module"" & @CRLF & _
"PID: WS-X4K-CLOCK-E , VID: V01 , SN: NWG161794PT" & @CRLF & _
"" & @CRLF & _
"NAME: "Mux Buffer 1 ", DESCR: "Mux Buffers for Redundancy Logic"" & @CRLF & _
"PID: WS-X4590-EX= , VID: , SN: NWG16179CP9" & @CRLF & _
"" & @CRLF & _
"NAME: "Mux Buffer 2 ", DESCR: "Mux Buffers for Redundancy Logic"" & @CRLF & _
"PID: WS-X4590-EX= , VID: , SN: NWG16179C3T" & @CRLF & _
"" & @CRLF & _
"NAME: "Mux Buffer 3 ", DESCR: "Mux Buffers for Redundancy Logic"" & @CRLF & _
"PID: WS-X4590-EX= , VID: , SN: NWG16179CUN" & @CRLF & _
"" & @CRLF & _
"NAME: "Mux Buffer 4 ", DESCR: "Mux Buffers for Redundancy Logic"" & @CRLF & _
"PID: WS-X4590-EX= , VID: , SN: NWG16179AXZ" & @CRLF & _
"" & @CRLF & _
"NAME: "Mux Buffer 7 ", DESCR: "Mux Buffers for Redundancy Logic"" & @CRLF & _
"PID: WS-X4590-EX= , VID: , SN: NWG16179CTE" & @CRLF & _
"" & @CRLF & _
"NAME: "Mux Buffer 8 ", DESCR: "Mux Buffers for Redundancy Logic"" & @CRLF & _
"PID: WS-X4590-EX= , VID: , SN: NWG16179C3V" & @CRLF & _
"" & @CRLF & _
"NAME: "Mux Buffer 9 ", DESCR: "Mux Buffers for Redundancy Logic"" & @CRLF & _
"PID: WS-X4590-EX= , VID: , SN: NWG16179CLW" & @CRLF & _
"" & @CRLF & _
"NAME: "Mux Buffer 10 ", DESCR: "Mux Buffers for Redundancy Logic"" & @CRLF & _
"PID: WS-X4590-EX= , VID: , SN: NWG16179CVU" & @CRLF & _
"" & @CRLF & _
"NAME: "Linecard(slot 1)", DESCR: "10/100/1000BaseT (RJ45)+V E Series with 48 10/100/1000 baseT Premium PoE ports (Cisco/IEEE)"" & @CRLF & _
"PID: WS-X4748-RJ45V+E , VID: V03 , SN: CAT1624L2J7" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")