re = /(^|(?<=[\s,;:.!?])+)[A-Za-z]+($|(?=[\s,;:.!?]+))/m
str = 'startword first second,third;fourth:not#word not1word: fifth,, ; sixth; preendword.endword
startword first second,third;fourth:not#word not1word: fifth,, ; sixth; preendword!endword
startword first second,third;fourth:not#word not1word: fifth,, ; sixth; preendword?endword'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end