$re = '/\[image:\WTrack\Wyour\Wpackage\]\W*?<(.*?)>/i';
$str = '
[image: Track your package]
<https://www.amazon.com/gp/r.html?C=D1F7PLME0YUL&K=AZB3XV0S80EZY&R=26TVFHC5RQEQB&T=C&U=https%3A%2F%2Fwww.amazon.com%2Fgp%2Fcsef%3Dpe_385040_215884940_TE_SIMP_typ%3FieaddressID%3Dme%3D1494399599%26orderID%3D11434-0549003%26shipme26orderingShipmentId%3D2064772822089%26packageId%3D1&A=CIOW7DNSTSMBXHW0GFTJMA&ref_=pe_3850440_TE_SIMP_typ>
[image: Your Orders]
<https://www.amazon.com/gp/r.html?C=D1F7PLME0YUL&K=AZB32Forder-details%3ForderId%3D114-7286434-0549003%26eoid%3D1%240_TE_SIMP_od>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);