// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mis)((object|inherited) \w+:[ ](TMgDBEdit).*?)((Color = clInactiveCaptionText\n)|(\n\s+end))").unwrap();
let string = " object Ed_PRO_ST_DESCRICAO: TMgDBEdit
Left = 132
Top = 81
Width = 675
Height = 21
AutoSize = False
Color = clInactiveCaptionText
DataField = 'PRO_ST_DESCRICAO'
DataSource = Dm_AdmInt.Ds_Produtos_
TabOrder = 4
OnChange = Ed_PRO_ST_DESCRICAOChange
OnExit = Ed_PRO_ST_DESCRICAOExit
OnKeyPress = Ed_PRO_ST_DESCRICAOKeyPress
Password = False
end
object Ed_PRO_ST_NARRATIVA1: TMgDBMemo
Left = 132
Top = 157
Width = 675
Height = 78
DataField = 'PRO_ST_NARRATIVA'
DataSource = Dm_AdmInt.Ds_Produtos_
MaxLength = 500
ScrollBars = ssVertical
TabOrder = 7
end
";
let substitution = "\\1ParentFont = True\\n";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}