#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\w+\-?\/)(\w+\-?\/)"
Local $sString = "/www.nytimes.com/2015/12/28/us/politics/how-hillary-clinton-went-undercover-to-examine-race-in-education.html?ref=todayspaper" & @CRLF & _
"http://www.nytimes.com/2015/12/28/arts/ellsworth-kelly-artist-who-mixed-european-abstraction-into-everyday-life-dies-at-92.html?ref=todayspaper" & @CRLF & _
"http://www.nytimes.com/2015/12/28/world/middleeast/more-and-more-special-forces-become-obamas-military-answer.html?ref=todayspaper" & @CRLF & _
"http://www.nytimes.com/2015/12/29/us/tamir-rice-police-shootiing-cleveland.html" & @CRLF & _
"http://www.nytimes.com/2015/12/29/world/middleeast/iraq-ramadi-isis.html" & @CRLF & _
"http://www.nytimes.com/2015/12/29/business/tsa-moves-closer-to-rejecting-some-state-drivers-licenses-for-travel.html" & @CRLF & _
"http://www.nytimes.com/2015/12/29/nyregion/mayor-de-blasio-still-trying-fitfully-to-blow-his-own-horn-better.html" & @CRLF & _
"http://www.nytimes.com/2015/12/29/world/middleeast/iran-hands-over-stockpile-of-enriched-uranium-to-russia.html" & @CRLF & _
"http://www.nytimes.com/2015/12/29/world/asia/comfort-women-south-korea-japan.html" & @CRLF & _
"http://www.nytimes.com/2015/12/29/us/tamir-rice-police-shootiing-cleveland.html?ref=todayspaper" & @CRLF & _
"http://www.nytimes.com/2015/12/29/world/middleeast/iraq-ramadi-isis.html?ref=todayspaper" & @CRLF & _
"http://www.nytimes.com/2015/12/29/world/americas/maritime-repo-men-a-last-resort-for-stolen-ships.html?ref=todayspaper" & @CRLF & _
"http://www.nytimes.com/2015/12/29/technology/universities-race-to-nurture-start-up-founders-of-the-future.html?ref=todayspaper" & @CRLF & _
"http://www.nytimes.com/2015/12/29/sports/basketball/meadowlark-lemon-harlem-globetrotter-who-played-basketball-and-pranks-with-virtuosity-dies-at-83.html?ref=todayspaper" & @CRLF & _
"http://www.nytimes.com/2015/12/29/world/asia/comfort-women-south-korea-japan.html?ref=todayspaper" & @CRLF & _
"http://www.nytimes.com/2015/12/30/business/economy/for-the-wealthiest-private-tax-system-saves-them-billions.html" & @CRLF & _
"http://www.nytimes.com/2015/12/30/us/affluenza-ethan-couch-mexico.html" & @CRLF & _
"http://www.nytimes.com/2015/12/30/us/use-of-affluenza-didnt-begin-with-ethan-couch-case.html" & @CRLF & _
"http://www.nytimes.com/2015/12/30/world/asia/book-says-zhou-enlai-chinese-premier-may-have-been-gay.html" & @CRLF & _
"http://www.nytimes.com/2015/12/30/world/middleeast/isis-ramadi-iraq.html" & @CRLF & _
"http://www.nytimes.com/2015/12/30/world/europe/us-says-airstrikes-killed-militants-tied-to-paris-attacks.html" & @CRLF & _
"http://www.nytimes.com/2015/12/30/business/economy/for-the-wealthiest-private-tax-system-saves-them-billions.html?ref=todayspaper" & @CRLF & _
"http://www.nytimes.com/2015/12/30/us/politics/ex-ally-donald-trump-now-heaps-scorn-on-bill-clinton.html?ref=todayspaper" & @CRLF & _
"http://www.nytimes.com/2015/12/30/us/more-police-officers-facing-charges-but-few-see-jail.html?ref=todayspaper" & @CRLF & _
"http://www.nytimes.com/2015/12/30/nyregion/bratton-rebukes-kelly-for-questioning-new-york-crime-data-shame-on-him.html?ref=todayspaper" & @CRLF & _
"http://www.nytimes.com/2015/12/30/us/affluenza-ethan-couch-mexico.html?ref=todayspaper" & @CRLF & _
"http://www.nytimes.com/2015/12/31/business/media/bill-cosby-charged-in-sexual-assault-case.html" & @CRLF & _
"http://www.nytimes.com/2015/07/19/arts/bill-cosby-deposition-reveals-calculated-pursuit-of-young-women-using-fame-drugs-and-deceit.html" & @CRLF & _
"http://www.nytimes.com/2015/12/31/world/europe/cellphone-contacts-in-paris-attacks-suggest-foreign-coordination.html" & @CRLF & _
"http://www.nytimes.com/2015/12/31/world/middleeast/muslims-on-twitter-say-they-have-better-things-to-do-than-join-isis.html" & @CRLF & _
"http://www.nytimes.com/2015/12/31/world/europe/belgium-brussels-police-orgy.html" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")