$re = '/frame[_]*(?P<fidx>\d{5,6})[_ .]|(?P<device_id>[0-9a-z]{16})_(?P<date>\d{8})_(?P<time>\d{6})_(?P<microseconds>\d{6})_(?P<frame_index>\d{6})/m';
$str = '/orcam/field_recordings/myear/recordings/2019/06/190611_141138_Unoaa_LOrcam_Cvoice_recording_check_911_up_V9_2_2_ear_en_US_dev_base25_mek6_Dmyear25/0000070d6f0af444_20160113_004600_8972/000.tar/frame_0000070d6f0af444_20160113_004911_761791_001718_BA81_e_8333.0_ag_12.0_dg_150_100_180.jpg';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);