$re = '/.*(\?example=.+?)(\?.*)/m';
$str = 'http://ikmultimedia.com
http://www.ikmultimedia.com
http://somethingelse.net?example=50?whatever=false
http://www.test.com?firstquery=dog?example=cat
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);