const regex = /^ip dhcp pool(\n|.)*?(?=!)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^ip dhcp pool(\\n|.)*?(?=!)', 'gm')
const str = `ip dhcp excluded-address 10.10.8.1 10.10.8.100
ip dhcp excluded-address 10.8.8.1 10.8.9.0
ip dhcp excluded-address 192.168.0.1 192.168.0.10
ip dhcp excluded-address 10.10.9.12
ip dhcp excluded-address 10.10.9.14
!
ip dhcp pool Pool1
network 10.10.8.0 255.255.248.0
update dns both override
dns-server 10.10.1.10 10.10.1.11
default-router 10.10.8.1
lease 8
!
ip dhcp pool Pool2
network 10.8.8.0 255.255.248.0
update dns both override
default-router 10.8.8.1
dns-server 10.10.1.10 10.10.1.11
lease 8
!
ip dhcp pool Pool3
network 192.168.0.0 255.255.255.0
update dns both override
dns-server 10.10.1.10 10.10.1.11
default-router 192.168.0.1
lease 8
!
ip dhcp pool Device1
host 10.10.10.84 255.255.248.0
client-identifier 0100.24ee.065d.3e
!
ip dhcp pool Device2
host 10.10.10.115 255.255.248.0
client-identifier 0194.c691.6a43.3f
!
ip dhcp pool Device3
host 10.10.10.250 255.255.248.0
client-identifier 0194.c691.fb53.7e
!
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}