re = /<span>(.*?)<\/span><br>/m
str = '<span>DH&A Team</span><br><span>Domain Users</span><br><span>DPE EDP Engineering All</span><br><span>G_Arrayras_Associate</span><br><span>G_Azure_App_GoGuide</span><br><span>g_azure_dha_dhap_devs_devtest</span><br><span>g_azure_dha_dhap_devs_npe</span><br><span>g_azure_dha_dhap_devs_prd</span><br><span>g_azure_dha_edp_devs_npe</span><br><span>g_azure_dha_edp_devs_prod</span><br><span>g_Azure_GitHub_Enterprise_Managed_User</span><br><span>g_Azure_Innersource_Members</span><br><span>G_Azure_Intune_PersonallyOwned</span><br><span>G_Azure_Jfrog_Artifactory</span><br><span>G_Azure_M365Apps_ZoomAddIn_Enabled</span><br><span>g_Azure_VSTS_DHA_PI_Eng_TEMP_OnS_Dev_Members</span><br><span>g_Azure_VSTS_DHA_PInE_EDP_Chassis_OnShore_TechAdmins</span><br><span>g_Azure_VSTS_DHA_PInE_EDP_DP_APaaS_OnShore_TechAdmins</span><br><span>g_Azure_VSTS_DHA_PInE_EDP_DP_ECOM_OnShore_TechAdmins</span><br><span>g_Azure_VSTS_DHA_PInE_EDP_DP_LHR_OnShore_TechAdmins</span><br><span>g_Azure_VSTS_DHA_PInE_EDP_DPFit_OnShore_TechAdmins</span><br><span>g_Azure_VSTS_DHA_PInE_EDP_Infra_OnShore_TechAdmins</span><br><span>g_Azure_VSTS_DHA_PInE_EDP_Interop_OnShore_TechAdmins</span><br><span>g_Azure_VSTS_DHA_PInE_EDP_PIE_OnShore_Members</span><br><span>g_Azure_VSTS_DHA_PInE_EDP_PIE_OnShore_TechAdmins</span><br><span>g_Azure_VSTS_DHA_PInE_EDP_Sec_OnShore_TechAdmins</span><br><span>G_Azure_VSTS_LicensedVia_Stakeholder</span><br><span>G_Azure_Zoom_Enabled</span><br><span>G_Azure_ZPA</span><br><span>G_Citrix_30Day_Outlook_Cache</span><br><span>G_HOME_LOUISILON02S_USERDAT01</span><br><span>G_humemp</span><br><span>G_O365_PST_Control</span><br><span>G_OracleDept_70360</span><br><span>G_TS_CHROME_BROWSER</span><br><span>G_TS_EDGE_BROWSER</span><br><span>G_TS_Humana_Intranet_Applications</span><br><span>G_TS_Psynch</span><br><span>G_TS_Web_Mail</span><br><span>G_VAS_AWS-TranscendDevQA</span><br><span>ServiceNow PPM Time Users</span><br><span>Targeted Associate List</span><br></div>'
subst = '$1\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result