const regex = /(?<DAY>\d?\d)(?<SEPARATOR>[-.\/])(?<MONTH>\d\d)(\k<SEPARATOR>)(?<YEAR>\d{4})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<DAY>\\d?\\d)(?<SEPARATOR>[-.\\\/])(?<MONTH>\\d\\d)(\\k<SEPARATOR>)(?<YEAR>\\d{4})', 'gm')
const str = `13-07-2020
8.07.2020
13/07/2020
13/07-2020`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}