#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(xcopy)|([A-Z]:\\[^\s\n]*)+"
Local $sString = "xcopy C:\test D:\target\backup\files F:\abc.text" & @CRLF & _
"" & @CRLF & _
"(xcopy)|([A-Z]:\\[^ \n]*)+"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")