import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-zA-Z][a-zA-Z=0-9;]*";
final String string = "3. 宿舍开水一壶价格已达到1元以上,%给学生用水造成很大负担。\n"
+ "4. 空调租赁机制不合理问题,%租赁只能以年为单位,但学生一般只在夏季使用,多出费用很多\n"
+ "5. 厕所洗手液没有%及时更换\n"
+ "matlab=123;%this is a matlab test function\n"
+ "Matlab=123;%this is a matlab test function";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}