re = /^(?:4[0-9]{12}(?:[0-9]{3})?|5[1-5][0-9]{14}|3[47][0-9]{13}|3(?:0[0-5]|[68][0-9])[0-9]{11}|6(?:011|5[0-9]{2})[0-9]{12}(?:2131|1800|35\d{3})\d{11})$/m
str = '4510123456781234
373342709912345
5410123412344567
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end