const regex = /^[^\s]*[a-z][^\s][.{1}][^\s\b]*[a-z][^.\b][^\s\b]$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^\\s]*[a-z][^\\s][.{1}][^\\s\\b]*[a-z][^.\\b][^\\s\\b]$', 'gm')
const str = `test.com
www.alexan.com
wander.economical.badnc.edu.org
https://website.com
wad.
wanders
WAD.ness
ww w.edu catio n.net`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}