// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"((?<func>latest|diff|avg|median|total|rollingmedian|rollingavg)\((?<par>[^(),]*),(?<uom>[^(),]*)(?:,(?<sp>[^()]*|))?\))|((?<func1>diffdays)\((?<par1>[^(),]*)(?:,(?<sp1>[^()]*|))?\))+").unwrap();
let string = "rollingmedian( ecoli, orgs/100mL, [tat10, tat11] ) + latest(ecoli,) + diffdays(ecoli)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}