const regex = /^[\u0980-\u09FF\s]+$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[\\u0980-\\u09FF\\s]+$', '')
const str = `জোবায়দুল ইসলাম`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}