// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?P<Timestamp>\b(?:Jan(?:uary)?|Feb(?:ruary)?|Mar(?:ch)?|Apr(?:il)?|May|Jun(?:e)?|Jul(?:y)?|Aug(?:ust)?|Sep(?:tember)?|Oct(?:ober)?|Nov(?:ember)?|Dec(?:ember)?)\s+\d+\s+\d+:\d+:\d+)\b\s+(?P<FW_ip_addr>\d+\.\d+\.\d+\.\d+)\s+(?P<Event_id>%\w+-\d+-\d+):\s+(?P<Event_message>Built (inbound|outbound) ICMP connection for faddr)\s+(?P<foreign_ip_addr>.*)\s+gaddr\s+(?P<global_ip_addr>.*)\s+laddr\s+(?P<local_ip_addr>.*)").unwrap();
let string = "Jul 25 23:57:18 210.56.128.109 %PIX-6-302020: Built outbound ICMP connection for faddr Odyssey_192.168.26.50/0 gaddr youngphoenix/35389 laddr youngphoenix/35389
Jul 25 23:57:34 210.56.128.109 %PIX-6-302020: Built inbound ICMP connection for faddr Thetis2/38748 gaddr 210.56.128.109/0 laddr 210.56.128.109/0";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}