$re = '/[A-Z]{5}\d{4}[A-Z]/m';
$str = 'AAAAA0001A';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);