use strict;
my $str = '123-456-5555
(123) 222-1234
123 555 5555
123.777.7979
+91 (123) 455-6000';
my $regex = qr/(?mx)
(?:\+?\(?\d{1,4}\)?\ ?\.?\-?)+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}