import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(021|031)";
final String string = "022 123-456-2322\n"
+ "021 123-456-2322\n"
+ "031 123-456-2377\n"
+ "041 123-456-2322\n"
+ "021 555-456-2322\n"
+ "031 555-456-2322\n"
+ "0341 555-456-2322\n"
+ "021 123-456-2377\n"
+ "0341 123-456-2377\n"
+ "0341 123-021-2377\n"
+ "0341 123-031-2377";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}