#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\d{5})(.{7})(.{5})\s(\-{4}|[A-Z]{4})\s(.{20})\s([\d.\s]{6})\s([\d.\-\s]{7})\s([\d\-\s]{5})\s.*$"
Local $sString = "99807 K3854 ---- BAD SEGEBERG 53.56 10.18 49 -12 LAND" & @CRLF & _
"99805 198 A762 ---- WITTENBORN 53.55 10.14 38 -2 LAND"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")