const regex = /^https:\/\/(?!.*\.clmbtech).*(?<!resources|shop|www|img|media\d)\.mensxp\.com\/(?!user|acms).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^https:\\\/\\\/(?!.*\\.clmbtech).*(?<!resources|shop|www|img|media\\d)\\.mensxp\\.com\\\/(?!user|acms).*', 'gm')
const str = `https://ade.clmbtech.com/cde/data/v4.htm?id=326762~1~0&_v=0&auds=all,5q6&_u=https%3A//m.mensxp.com/relationships/paternity/53523-gentlemen-here-rsquo-s-the-perfect-father-rsquo-s-day-gift-for-your-old-man.html&_t=3&_c=colombiaadCallback&fpc=8426c49b-8cee-4b94-be31-dc832516c339-1slg4&r=x308x346n64&dpv=1&ds=1191
https://ade.clmbtech.com/cde/data/v4.htm?id=326762~1~0&_v=0&auds=all,5q6&_u=https%3A//m.mensxp.com/sports/cricket/51684-pakistan-s-ahmed-shehzad-dropping-a-dolly-then-calling-for-a-review-is-the-funniest-thing-ever.html&_t=3&_c=colombiaadCallback&fpc=05a94bf4-8c22-4014-928d-1165710e6fe8-1sj20&r=i304h214R46&dpv=1&ds=1191
https://m.mensxp.com/acms/jsAds/getContent?ad_classid=727500184&kIeD=-433351922&admid=943709851&blkV=-1149826858
https://m.mensxp.com/social-hits/news/53825-man-offered-lsquo-dad-hugs-rsquo-at-a-pride-parade-to-kids-rejected-by-their-families-won-every-heart.html
https://www.mensxp.com/sports/cricket/53836-here-are-all-the-records-england-broke-during-their-decimation-of-afghanistan-at-old-trafford.html
https://shop.mensxp.com/?utm_source=mxp&utm_medium=menuhead
https://m.mensxp.com/culture.html
https://m.mensxp.com/sports/cricket/53836-here-are-all-the-records-england-broke-during-their-decimation-of-afghanistan-at-old-trafford.html
https://m.mensxp.com/api/ajax/get-user-activity/53523/save
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}