use strict;
my $str = '2021-06-15 10:41:04 SMM MANUAL MANUAL 6 7 manually switch OK
2021-09-03 14:32:01 UPS SW FAIL SW RESTART 8 - Error cnt: 1;err code:DAEMON_ERR_RESTART, param:
2021-09-03 14:35:04 UPS SW FAIL SW RESTART 13 - Error cnt: 1;err code:DAEMON_ERR_RESTART, param:
2021-09-03 14:32:01 UPS SW FAIL SW RESTART 8 - Error cnt: 1;err code:DAEMON_ERR_RESTART, param:
2021-06-22 14:15:43 QAM SYSTEM SWITCH BACK 5 0
2021-06-22 14:05:20 UPS SYSTEM SWITCH BACK 8 13
2021-06-22 13:41:25 QAM MANUAL MANUAL 0 5
2021-06-22 13:33:20 UPS MANUAL MANUAL 13 8
2021-06-15 12:12:15 QAM SYSTEM SWITCH BACK 5 0
2021-06-15 11:38:02 QAM MANUAL MANUAL 0 5
2021-06-15 11:35:35 UPS SYSTEM SWITCH BACK 8 13
2021-06-15 11:03:35 UPS MANUAL MANUAL 13 8 ';
my $regex = qr/(\d+\-\d+\-\d+)\s(\d+:\d+:\d+)\s+(\w+)\s+(\w+\s+?\w+)\s+(\w+\s+?\w+)\s+(\d+)\s+([-\d+])\s+(.*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}