$re = '/<a(?!.*<\/a>$)/i';
$str = 'Hehe i am here.. <a href="fb.com">facebook...';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);