import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<Group id=\"\\d+\">\\n\\t\\t\\t<Name>)(\\w+)_(\\w+)(<\\/Name>\\n\\t\\t\\t<Description>)([\\w+\\s]+)\\s-\\s([\\w+\\s]+)(<\\/Description>)";
final String string = " <Group id=\"100\">\n"
+ " <Name>generalAlarm_Group01</Name>\n"
+ " <Description>Group General Alarm 01</Description>\n"
+ " <Type>poll</Type>\n"
+ " <Content multipleGet=\"true\">\n"
+ " <Param>100</Param>\n"
+ " <Param>101</Param>\n"
+ " <Param>103</Param>\n"
+ " <Param>104</Param>\n"
+ " <Param>120</Param>\n"
+ " <Param>121</Param>\n"
+ " </Content>\n"
+ " </Group>\n"
+ " <Group id=\"110\">\n"
+ " <Name>generalConfig_Group01</Name>\n"
+ " <Description>Group General Config 01</Description>\n"
+ " <Type>poll</Type>\n"
+ " <Content multipleGet=\"true\">\n"
+ " <Param>105</Param>\n"
+ " <Param>106</Param>\n"
+ " <Param>107</Param>\n"
+ " <Param>108</Param>\n"
+ " <Param>109</Param>\n"
+ " <Param>110</Param>\n"
+ " <Param>111</Param>\n"
+ " <Param>112</Param>\n"
+ " <Param>113</Param>\n"
+ " </Content>\n"
+ " </Group>\n"
+ " \n"
+ " <Group id=\"1000\">\n"
+ " <Name>firstPriorityAlarmConfig_Group1000</Name>\n"
+ " <Description>First Priority Alarm Config Table - Group 1000</Description>\n"
+ " <Type>poll</Type>\n"
+ " <Content multipleGet=\"true\">\n"
+ " <Param>1000</Param>\n"
+ " </Content>\n"
+ " </Group>\n"
+ " <Group id=\"2000\">\n"
+ " <Name>secondPriorityAlarmConfig_Group2000</Name>\n"
+ " <Description>Second Priority Alarm Config Table - Group 2000</Description>\n"
+ " <Type>poll</Type>\n"
+ " <Content multipleGet=\"true\">\n"
+ " <Param>2000</Param>\n"
+ " </Content>\n"
+ " </Group>\n"
+ " <Group id=\"3000\">\n"
+ " <Name>thirdPriorityAlarmConfig_Group3000</Name>\n"
+ " <Description>Third Priority Alarm Config Table - Group 3000</Description>\n"
+ " <Type>poll</Type>\n"
+ " <Content multipleGet=\"true\">\n"
+ " <Param>3000</Param>\n"
+ " </Content>\n"
+ " </Group>";
final String subst = "$1$3_$2$4$6 - $5$7";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}