re = /^([a-z0-9]+(?:[._-][a-z0-9]+)*)@([a-z0-9]+(?:[.-][a-z0-9]+)*\.[a-z]{2,})$/i
str = 'namelogin@dom1.org'
# Print the match result
str.match(re) do |match|
puts match.to_s
end