package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)^(>|\/>|a\/>|[^<]*<a\/>)`)
var str = `.com<a/> <a>hehe</a>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}