re = /^[\da-zA-Z0-9\-\_]{16,16}$/m
str = 'ywrckisnxiwfwl2m
fxr1qtqhezpgno-z
(not set)
9ccvg3l-yu40n5kg+aem_ax8r7jqa2j3ad-twccvdltuod3ebjlzpqiypepb7awmspq7mfjptu6jsy_t1u-4naid3djgae8f1xz6xhecbb039j8jkm23xqbssi-byo3ktgg
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end