import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\-\\s\\*patient\\ssafety\\:\\*";
final String string = "- *Financial:* <yes or no. If yes, explain why>\n"
+ "- *Legal/Regulatory:* <yes or no. If yes, explain why>\n"
+ "- *Data Integrity:* <yes or no. If yes, explain why>\n"
+ "- *Patient Safety:* <yes or no. If yes, explain why>\n"
+ "- *CyberSecurity/Information Security:* <yes or no. If yes, explain why>\n\n"
+ "- *Financial:* <yes/no>\n"
+ "- *Legal/Regulatory:* <yes/no>\n"
+ "- *Data Integrity:* <yes/no>\n"
+ "- *Patient Safety:* <yes/no>\n"
+ "- *CyberSecurity/Information Security:* <yes/no>\n\n"
+ "- *Financial:* <yes or no. If yes, explain why>No\n"
+ "- *Legal/Regulatory:* <yes or no. If yes, explain why> Yes\n"
+ "- *Data Integrity:* No\n"
+ "- *Patient Safety:* Yes, this was an issue because of XYZ.\n"
+ "- *CyberSecurity/Information Security:* <yes or no. If yes, explain why>\n\n"
+ "- *Financial:* no\n"
+ "- *Legal/Regulatory:* no\n"
+ "- *Data Integrity:* no\n"
+ "- *Patient Safety:* no\n"
+ "- *CyberSecurity/Information Security:* no\n\n"
+ "- *Financial:* N\n"
+ "- *Legal/Regulatory:* N\n"
+ "- *Data Integrity:* N\n"
+ "- *Patient Safety:* N\n"
+ "- *CyberSecurity/Information Security:* N\n\n"
+ "- *Financial:* <yes or no. If yes, explain why>N\n"
+ "- *Legal/Regulatory:* <yes or no. If yes, explain why> N\n"
+ "- *Data Integrity:* <yes or no. If yes, explain why>N\n"
+ "- *Patient Safety:* <yes or no. If yes, explain why>N\n"
+ "- *CyberSecurity/Information Security:* <yes or no. If yes, explain why> N\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}