const regex = /([\-]*BEGIN\sCERTIFICATE\sREQUEST[\-]+.+[-]+END\sCERTIFICATE\sREQUEST[-]+)/gmysi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\\-]*BEGIN\\sCERTIFICATE\\sREQUEST[\\-]+.+[-]+END\\sCERTIFICATE\\sREQUEST[-]+)', 'gmysi')
const str = `-----BEGIN CERTIFICATE REQUEST-----
MIIEuDCCAqACAQAwczELMAkGA1UEBhMCVVMxGDAWBgNVBAMMD3BsdWdpYmlsaXR5
LmNvbTEXMBUGA1UEBwwOU2FsdCBMYWtlIENpdHkxFDASBgNVBAoMC1BsdWdpYmls
aXR5MQ0wCwYDVQQIDARVdGFoMQwwCgYDVQQLDANPcmcwggIiMA0GCSqGSIb3DQEB
AQUAA4ICDwAwggIKAoICAQCfQqx8YexJ4HjGqIpywxvTOPDnqIaZicD3IQSUdAb5
5vcfAaD/0KBH/6Oa2NPlq4mYAw2octDiuklvkXIUgnn85vwlj6fLm6iR6i1tjM3g
tusxur3fmMdF9YqDNNM7LVSxXMq/vXuChPj3bVib2EyKJRcBn8EMTnJYdfl3YK4l
j+KW7cnxIy8E3DAy4KIUPbI2LNPix43emW6XuMB3hpvcbs2YpQogagAQwvNYAIcW
Ub3+fSEbXFNVmYFRPbd7T5Arei4Ubl8kKVWfqUnWIOdYQh7o0CbQl+67ivAyRnDU
oItNtPz+seWzL1xerjQqdlHrCQFGNfLdI3Hfl9SZVKOqdsjs2bEiP+C6E/pilvu/
zEtD5VbGd0UBBZtANm6BdBEhhigX8vL/FfiqxlPsEK31L9tQnwa6ETvcVbRQoXBW
idJJKCmiScz17ML8aTxw0zXc16CBHuE4AEV7xaNmdl5NsYCB+q/H3SCVsreMnu7A
cpCgvaCZX1/8zSWrVNMf0i+/gJCoBh1OXNnqtCPycJDPvrVGYF2U7RqzC4c91Kqe
QxEKHApEJAL47nFtM9c3K2fNvLEVOD+k+iDkEuL++VHaXO3VHCiVoJjQCSNTChl3
aSL29LadjcPvf2QdMymEJ4+wKI8u6l1bk51zN0INnVDDkMdtfCu0C8ux8M4roP9Y
kQIDAQABoAAwDQYJKoZIhvcNAQELBQADggIBAJO3HIp2hvkQh6/Bk19RiEdyfJjb
xoPWtfM4lWDyXLxq6HrmKadvOtjTs9fGpoBRJaknIhy8n0/oN8Et+uFgga3ptb/8
AjyDRVqmYK3byAJrUm055v9VseNwFqE/hsZiFtPMVA5I5agtnQm8o6zPgUSMQWso
evA00Fa+Q1X1Hmbthtd2ZH64cxLOqW3vW9LViBp9C52mU1NyZtvPRJAlcOlH1r9A
MFnPrR7T4HJ8gMEvaj0likFr5nQKWH5ScPvHbIKyIoebn9RznbMZBNjUn60+I0Kt
VwN8UrIwZMNF+eL99I6kEr/gjoZ3VegPH7YaVRQ280L4NvZNKMbAr1Z+uyCD587y
Zf+cbzZB30xTfra0/iUQnGEBuScpGQMdXEzmE/lBCnNnqnNohrAwvQNLISbnK7w2
JUrwbIIgRrLmmXGELPQ7vBkKmCtSrmPGLyWctwG005h8hHLtFk8jagSDJ/gTQ3Wv
n7YEy3ROHujz/UVGrGE2P3oKs5prn+N52HIxM9XoaQndrtbyvkaOe+WHGZ0htQkE
H6Rrh0YijAFpZTsKwv1ndMh2HpoaYX3B1s9ky3TWGAdOMCgHgdBFpvk2+PdDN+6a
Js+0VtfRywLxxaEamLciBj6JmjybIEBSANSwf2pdn8OnMq5BLZrLRWhsaMVGlciL
1JPHcsgLz1lD8FYC
-----END CERTIFICATE REQUEST-----
-----BEGIN PRIVATE KEY-----
MIIJQgIBADANBgkqhkiG9w0BAQEFAASCCSwwggkoAgEAAoICAQCfQqx8YexJ4HjG
qIpywxvTOPDnqIaZicD3IQSUdAb55vcfAaD/0KBH/6Oa2NPlq4mYAw2octDiuklv
kXIUgnn85vwlj6fLm6iR6i1tjM3gtusxur3fmMdF9YqDNNM7LVSxXMq/vXuChPj3
bVib2EyKJRcBn8EMTnJYdfl3YK4lj+KW7cnxIy8E3DAy4KIUPbI2LNPix43emW6X
uMB3hpvcbs2YpQogagAQwvNYAIcWUb3+fSEbXFNVmYFRPbd7T5Arei4Ubl8kKVWf
qUnWIOdYQh7o0CbQl+67ivAyRnDUoItNtPz+seWzL1xerjQqdlHrCQFGNfLdI3Hf
l9SZVKOqdsjs2bEiP+C6E/pilvu/zEtD5VbGd0UBBZtANm6BdBEhhigX8vL/Ffiq
xlPsEK31L9tQnwa6ETvcVbRQoXBWidJJKCmiScz17ML8aTxw0zXc16CBHuE4AEV7
xaNmdl5NsYCB+q/H3SCVsreMnu7AcpCgvaCZX1/8zSWrVNMf0i+/gJCoBh1OXNnq
tCPycJDPvrVGYF2U7RqzC4c91KqeQxEKHApEJAL47nFtM9c3K2fNvLEVOD+k+iDk
EuL++VHaXO3VHCiVoJjQCSNTChl3aSL29LadjcPvf2QdMymEJ4+wKI8u6l1bk51z
N0INnVDDkMdtfCu0C8ux8M4roP9YkQIDAQABAoICAGRnX2DnR1Vn/ByaQvaJBPDM
NCyINZt0mj/zA/UnlQJV1zQoDb1ZZMMfaqCD1Es2Mv+v5RtujzxxXzzEQFynyYpk
gVCY2Ztmngan0U4AeAcUqwBmD7B4nCEB5PpFAmqLcJqEupnZNpWZiXBL8pIF8nMh
YPi4I7fDeRlF/ymAvSmXJa4raaXpnYn92zEoJ2aFYuX+qvKNBmbw6iUi58wzA+4b
uOhkHBdFXJc0oL+5TXEHxbU8Y/Pg5/TOWxXBx/wos+aFF6nvz3F30bBfxNoHUnJ0
9RGnsODO+EYqGLZJbHbQZCJwWROlSgAGesCCKQcgIxL/UVtXRa6e2vqwuOqVzrv5
msBFM/HzcUvdtNq4FP2UfcqAi4FZlwHlbTDphE3fZSPbLIoJZLuhKuJPFA/Sc8L/
ABPnmRqb0bZ2RKECBnXrsV0U/KeSxbY4r0Hj+ggBnLNO1VhlYjCQZlCXA4X8LdyV
wBvoNeKjSo3ZD8vr/Jvpdm/9xiWVikbPqYpiEiIn6iN8omYWjxHWgDox9fd+zVQu
c/3giKEVAQYhNYj+YbkZpmnWQNjdL89TatjdBeaWO9Zq4k1VwN5UYB539O61kHfC
bhpYx/ptIgTBdEwp+ohlkAegCyBS+Mo3SiQocATdpeBwAMoMpMOtCiMDyGjydK0Y
2xi5+uOGMDKMbWvRe10FAoIBAQDMnaqknzt8Brc1KHQVv7Ww0VTrCEjItXLaAIOs
AW9PyL6/9lhFYljCnEGcWL3LAZlhldr81aNE40qw5FVVRrTR2Hg3xF/znZwa6Bnc
0t1XXGRj0BZIH5OrZSdf0gXdEwIrIB2LmllxMMpzd0BSgX/+x6k2K6FMAl/048bg
v986GsRwUjrlkt0ihyQNHlWuKKK82W1G6G4iQiC0bD5i/AUBer9o5Yb4X9GrgoIA
nWJIHstfJ80KTOJMQVczj0SKLmTjnIUE91BcXGhqTTdcSKTWbts50HyuwQAYcZco
vW5B5Sbyf57jCvu68Bo3gxngE1xYjtTR6Q13azII4DxyE7MjAoIBAQDHQTMNW8NQ
unvr64yqCwzBmEmpCJ6NEbYub3rqHzQPe5Na5VN1iTujKx5ifhi5uhR5A5Jluy2O
fUWzF/ihEdVOOh0JPj1NiJkY1VkuiY9Y2aHR2+8st06sp92Zj1i7Us/t+CP+WuOv
m7He4xRRrXx9tXcdpAzaTr8NoKXCL1fz4t8HKUZdfvvCtY+Ghd3ct1rEG8Bi9SUF
yBoTE1NwATHLCsYFURhpmWwnQTMpRTjlhogNSywDG59fdcqyEBUacCnPG7ZxZ3c2
N8VWknZsf9hBEyjyGCvTNq1A0KKJ6PIEp2gOoMi4I1nbKB1jSC7Gh61pJ+aV4L6g
M10Jh890RWq7AoIBAQC8vvv4G0Jd6Dv79zMOFOffEVpJ7DxnmKk3W54afsBVUpJS
tUU7y7qg2k7TkDCTIQiBsiBtdgzDsP7nKdllbnHB2PMcTjNMoCit0Uh6ILE4suuP
/xVutmIbipXFmBD8m1o2uctHSbwT47P8yxY0hWyycy8t3xVM7ivh1HNSQuwBx0tJ
aTEXMGB4Rz0ENOVIYAeuOMrKzAE77NAKXoc1+9AKS1Zhxsi4OHtKwHp3YraUXIOx
ZR+Izt85BFUSJKhO5vj91RYHPLOOX1eaJ1xX7lLP0za6oA1Djpkt8ypC1Grushk5
PGwud6U6Dd3BM1gdEP7wWeELOPXJIMLo2SApAu8NAoIBAGjYmPl9gJ/ZEN4KOyE6
4UJ5VME6RNusJzX1+TJ6qtU+zEH3C9x8EsKALOPcwDvye1VWGNGpFYa1ylg709tF
W/1mvOKhOnay2wRjNyMyxRgWpHyeAxN/fUmCpytnb2RaZgktGht8TfSYs5a53HZC
GJC5TO1u5kh1STjtgGtWqCwwA/VrtZf6+pTxHo3FoQHEBWHNzIUFw65wJbBF6hC0
wDO7/ojLrFHcpjldqIMd5pt4F90O4iDchxcfD0J1DfW0cXuGdJDlxafk3tT4CpJ7
Dxrm7xO8vkrMqYvCfNSem8LxJ+MSnauvBlg4moYkdGCJAimkEkRpV0VK4bjjGrlu
0YMCggEAGftF1dJBqkUKc9dsbSQYwwfaU+W/gFWU4otTPd89HIOVkKyz3Hc0FrEH
68Ffrlx1MZU8wbNjjXytujJ7vwn0+n0bXN+5/oqEM+zlVunefCCLWWVLD0Sc/yOx
llgrU9u2z8Zjjl+mbbWNKhjV6oBNw3qi4CNHiBMHQk98xGQaRaTh/t/laXxZgtIo
Y+mZN7OXk3IUv6xlO+OyneG+CU9/VOPszLK9yFf95m9l5R6E6v9r4eE9N5OMOTxT
SBXZ+zNnnF4bIjy747KtCVI7XJQURDBbhhXick/lgX6sNj87vMaDJDnZ9kqqgc3U
1H23mg7nAvcEhsYClM3Z8/bEH6eRBQ==
-----END PRIVATE KEY-----
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}