re = /(?P<num_dice>\d+)[dwDW](?P<die_size>\d+)(?P<modifier>[\+\-]\d+)?/
str = '7D2-10'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end