$re = '/(\d{1,3})\.(\d{1,3})\.(\d{1,3})\.(\d{1,3})/m';
$str = '192.168.12.1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);