#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=class=["'][\w\- :\.]*)([\w\-:\.]+)"
Local $sString = "<div class="px-4 sm:px-6 lg:px-8">" & @CRLF & _
" <div class="sm:flex sm:items-center">" & @CRLF & _
" <div class="sm:flex-auto">" & @CRLF & _
" <h1 class="text-xl font-semibold text-gray-900">Users</h1>" & @CRLF & _
" <p class="mt-2 text-sm text-gray-700">A list of all the users in your account including their name, title, email and role.</p>" & @CRLF & _
" </div>" & @CRLF & _
" <div class="mt-4 sm:mt-0 sm:ml-16 sm:flex-none">" & @CRLF & _
" <button type="button" class="inline-flex items-center justify-center rounded-md border border-transparent bg-indigo-600 px-4 py-2 text-sm font-medium text-white shadow-sm hover:bg-indigo-700 focus:outline-none focus:ring-2 focus:ring-indigo-500 focus:ring-offset-2 sm:w-auto">Add user</button>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" <div class="mt-8 flex flex-col">" & @CRLF & _
" <div class="-my-2 -mx-4 overflow-x-auto sm:-mx-6 lg:-mx-8">" & @CRLF & _
" <div class="inline-block min-w-full py-2 align-middle">" & @CRLF & _
" <div class="overflow-hidden shadow-sm ring-1 ring-black ring-opacity-5">" & @CRLF & _
" <table class="min-w-full divide-y divide-gray-300">" & @CRLF & _
" <thead class="bg-gray-50">" & @CRLF & _
" <tr>" & @CRLF & _
" <th scope="col" class="py-3.5 pl-4 pr-3 text-left text-sm font-semibold text-gray-900 sm:pl-6 lg:pl-8">Name</th>" & @CRLF & _
" <th scope="col" class="px-3 py-3.5 text-left text-sm font-semibold text-gray-900">Title</th>" & @CRLF & _
" <th scope="col" class="px-3 py-3.5 text-left text-sm font-semibold text-gray-900">Email</th>" & @CRLF & _
" <th scope="col" class="px-3 py-3.5 text-left text-sm font-semibold text-gray-900">Role</th>" & @CRLF & _
" <th scope="col" class="relative py-3.5 pl-3 pr-4 sm:pr-6 lg:pr-8">" & @CRLF & _
" <span class="sr-only">Edit</span>" & @CRLF & _
" </th>" & @CRLF & _
" </tr>" & @CRLF & _
" </thead>" & @CRLF & _
" <tbody class="divide-y divide-gray-200 bg-white">" & @CRLF & _
" <tr>" & @CRLF & _
" <td class="whitespace-nowrap py-4 pl-4 pr-3 text-sm font-medium text-gray-900 sm:pl-6 lg:pl-8">Lindsay Walton</td>" & @CRLF & _
" <td class="whitespace-nowrap px-3 py-4 text-sm text-gray-500">Front-end Developer</td>" & @CRLF & _
" <td class="whitespace-nowrap px-3 py-4 text-sm text-gray-500">lindsay.walton@example.com</td>" & @CRLF & _
" <td class="whitespace-nowrap px-3 py-4 text-sm text-gray-500">Member</td>" & @CRLF & _
" <td class="relative whitespace-nowrap py-4 pl-3 pr-4 text-right text-sm font-medium sm:pr-6 lg:pr-8">" & @CRLF & _
" <a href="#" class="text-indigo-600 hover:text-indigo-900">Edit<span class="sr-only">, Lindsay Walton</span></a>" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
"" & @CRLF & _
" <!-- More people... -->" & @CRLF & _
" </tbody>" & @CRLF & _
" </table>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
"</div>"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)