using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(url\s*\([^()]+\))|(@import[^;]+;)";
string input = @"@import ""//static001.geekbang.org/static/infoq/www/css/app.0d41a85d7b732aac5d44bdf04a8b642c.css"";
@font-face {
font-family: layui-icon;
src: url(http://foo.com/font/iconfont.eot?v=230-rc1);
src: url(http://foo.com/font/iconfont.eot?v=230-rc1#iefix) format('embedded-opentype'),url(//foo.com/font/iconfont.svg?v=230-rc1#iconfont)
}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}