import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\(*(\\w{3})[-_~\\s*\\.]*?(\\d{1,}|\\d*.\\d*.\\d*)[-_\\s.~]*?(FTP|IMG|SCR|LIV|TVU).?-?\\s?(\\w{3}).\\s?-?_?~?\\.?(\\d*).\\s?-?~?_?\\.?(.*)";
final String string = "((NWS_20-12-19_FTP_VLR_01_This is a test message))\n"
+ "(NWS 11219 LIV TNL 02 Second test message)\n"
+ "(((NWS~11/12/2019~IMG-KNK-4-third_test_message)))\n"
+ "(NWS-12-12-19-SCR-TVM-03-Fourth-test-message))\n"
+ "((NWS - 12.12.2019 - FTP - CGP -5 - fifth test message)\n"
+ "(NWS_12.12/19~FTP-CHN 01_sixth test message ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}