# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:(?P<Date>(?:Mon|Tue|Wed|Thu|Fri|Sat|Sun), (?:Jan|Feb|Mar|Apr|May|Jun|Jul|Aug|Sep|Oct|Nov|Dec) \d{1,2}, \d+ \d{1,2}:\d{1,2} AM|PM) (?P<WarnID>(?:[0-9a-f]|-)*) (?P<User>[a-zA-Z]+#[0-9]{4}) (?:\((?P<UserID>[0-9]+)\)) (?P<Moderator>[a-zA-Z]+#[0-9]{4}) (?P<WarnReason>(?:\s|\S)+))"
test_str = "Fri, Apr 21, 2023 7:49 AM 6ab4e8de-262b-4926-a12e-646863749f35 Fir#7634 (750565290009559112) HitByaThunder#1925 continuing to make giveaways after being told to stop. fir, stop if you're asked to Stop"
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.