# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<= Name:)[\s]+[\d\w]+"
test_str = "\" Primary Location: MO0134 Name: 8930 WARD PKY FEDERAL BG Ownership: Federal Status: Active Address: 8930 WARD PKWY, KANSAS CITY, MO 64114 Facility Code: (None) Facility Name: (None) File Name: STRUCT-17110-GSA_WARDPKWY - R18.RVT File Title: Struct-17110-GSA-WardPkwy-R18.rvt Timeframe: Future Conditions Primary Context: PROJ 1234567 Title: (None) Year: (None) Sub-Context: (None) Title: (None) Lifecycle Stage: Site Acquisition Document Type: BIM Sheet Type: (None) Plan Type: (None) Disciplines Process Equipment Resource Building Levels: (None) Program Association: (None) Description: Struct-17110-GSA-WardPkwy-R18.rvt Mimetype: application/x-tika-msoffice Author: (None) Size: 26808320 Creator: admin Created Date: Mon 24 Jan 2022 00:19:41 UTC Modifier: jason.zhang@gsa.gov Modified Date: Thu 07 Jul 2022 04:05:50 UTC \""
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.