import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?#regexp & naming based on RFC5424)\n"
+ "^<(?<priority>\\d|\\d{2}|1[1-8]\\d|19[01])>(?<version>\\d{1,2})\\s\n"
+ "(?<timestamp>-|(?<fullyear>[12]\\d{3})-(?<month>0\\d|[1][012])-(?<mday>[012]\\d|3[01])T(?<hour>[01]\\d|2[0-4]):(?<minute>[0-5]\\d):(?<second>[0-5]\\d|60)(?#60seconds can be used for leap year!)(?:\\.(?<secfrac>\\d{1,6}))?(?<numoffset>Z|[+-]\\d{2}:\\d{2})(?#=timezone))\\s\n"
+ "(?<hostname>[\\S]{1,255})\\s\n"
+ "(?<appname>[\\S]{1,48})\\s\n"
+ "(?<procid>[\\S]{1,128})\\s\n"
+ "(?<msgid>[\\S]{1,32})\\s\n"
+ "(?<structureddata>-|(?:\\[.+?(?<!\\\\)\\])+)\n"
+ "(?:\\s(?<msg>.+))?$";
final String string = "<165>1 2003-08-24T05:14:15.000003-07:00 192.0.2.1 myproc 8710 - - %% It's time to make the do-nuts.\n\n"
+ "<34>1 2003-10-11T22:14:15.003Z mymachine.example.com su - ID47 - BOM'su root' failed for lonvick on /dev/pts/8\n\n"
+ "<190>1 2003-10-11T22:14:15.003Z mymachine.example.com evntslog - ID47 [exampleSDID@32473 iut=\"3\" eventSource=\"Application\" eventID=\"10\\] 11\"] BOMAn application event log entry..[ ] sadasd\n\n"
+ "<25>1 2003-10-11T22:14:15.003Z mymachine.example.com evntslog - ID47 [exampleSDID@32473 iut=\"3\" eventSource=\"Application\" eventID=\"1011\"][examplePriority@32473 class=\"high\"]\n\n"
+ "<1>12 - mymachine - - ID47 - asd asdaasd";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}