$re = '/([+-]?)\s*(?:(?:(?:[^.([{]?(\d+))|(\d+\.\d+(?!\w+)))(?!\w+|\.))(?![([{])/';
$str = '2 + 2.2b - 2 + b + 2.2(2 - 2) + 2(- 2 - 2.2 + 2)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);