using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((([a-z0-9][a-z0-9\-]*[a-z0-9])|[a-z0-9])\.?)+$";
string input = @"dicas-l.com.br";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}