package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((^|,)(?<column>[^,]*))+`)
var str = `a,012,,xxxxx
((^|,)(?<column>[^,]*))+`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}