# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"public ([\w><]+ [\w><]+\(\))\s+{[^}]+}"
test_str = ("using System.Linq;\n"
"using NineYi.ERPV2.DA.AppDB.Tables;\n\n"
"namespace NineYi.ERPV2.DA.Repositories.DbRepositories\n"
"{\n"
" /// <summary>\n"
" /// AppDbRepository\n"
" /// </summary>\n"
" public class AppDbRepository : IAppDbRepository\n"
" {\n"
" /// <summary>\n"
" /// AppDbContext\n"
" /// </summary>\n"
" private AppDbContext _appDbContext;\n\n"
" /// <summary>\n"
" /// Initializes a new instance of the <see cref=\"AppDbRepository\" /> class.\n"
" /// </summary>\n"
" /// <param name=\"appDbContext\">AppDbContext</param>\n"
" public AppDbRepository(AppDbContext appDbContext)\n"
" {\n"
" this._appDbContext = appDbContext;\n"
" }\n\n"
" /// <summary>\n"
" /// SaveChanges\n"
" /// </summary>\n"
" public void SaveChanges()\n"
" {\n"
" this._appDbContext.SaveChanges();\n"
" }\n\n"
" /// <summary>\n"
" /// QueryUserCoupons \n"
" /// </summary>\n"
" /// <returns>UserCoupons</returns>\n"
" public IQueryable<user_coupon> QueryUserCoupons()\n"
" {\n"
" return this._appDbContext.user_coupon;\n"
" }\n\n"
" /// <summary>\n"
" /// QueryPubContents \n"
" /// </summary>\n"
" /// <returns>PubContents</returns>\n"
" public IQueryable<pub_content> QueryPubContents()\n"
" {\n"
" return this._appDbContext.pub_content;\n"
" }\n"
" }\n"
"}")
subst = "\\1;"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.