package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\s*(\d+)\s*:\s*(\d+)\s*,\s*`)
var str = ` 12: 3, 4,5 `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}