# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((?:Jan(?:uary)?|Feb(?:ruary)?|Mar(?:ch)?|Apr(?:il)?|May|Jun(?:e)?|Jul(?:y)?|Aug(?:ust)?|Sep(?:tember)?|Oct(?:ober)?|(Nov|Dec)(?:ember)?)(\s)([1,2][\d]|[1-9]|30|31)(\s))?(\b[\d]|10|11|12):[0-5][0-9]\s(AM|PM)"
test_str = ("March 9 12:31 AM and March 10 7:30 AM\n"
"March 11 7:30 AM and March 12 10:30 AM\n"
"Mar 31 9:00 PM and Apr 1 12:39 AM\n"
"March 31 10:11 PM and April 1 5:23 AM\n"
"7:45 PM and 10:30 PM\n"
"May 3 4:41 PM PDT and May 4 12:19 AM PDT\n"
"March 31 10:71 PM and April 1 5:23 AM\n"
"27:45 PM and 10:80 PM\n"
"May 3 4:41 PM PDT and May 41 12:19 AM PDT")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.