#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)First Name[\s\S](?<firstname>.*)[\s\S]Last Name[\s\S](?<lastname>.*)[\s\S]Phone[\s\S](?<phone>.*)[\s\S]E-Mail[\s\S](?<email>.*)[\s\S]*age group\?[\s\S](?<agegroup>.*)[\s\S]*seeing things up close[\s\S](?<farsightedness>.*)[\s\S]*cannot see very well[\s\S](?<astigmatism>.*)[\s\S]*-Glasses[\s\S](?<glasses>.*)[\s\S]*-Contacts[\s\S](?<contacts>.*)[\s\S]*-Reading Glasses[\s\S](?<readingglasses>.*)[\s\S]*following\?-(?<following>.*)[\s\S]*distance without relying on glasses and contact lenses.[\s\S](?<distance>.*)[\s\S]*close without relying on glasses and contact lenses.[\s\S](?<close>.*)[\s\S]*contacts\?[\s\S](?<wouldyourcareerimprove>.*)[\s\S]*Test Score[\s\S](?<testscore>.*)[\s\S]*Entry ID: (?<entryid>.*)[\s\S].*Referrer: (?<referrer>.*)[\s\S]*Host: (?<formhost>.*)"
Local $sString = "First Name Melissa" & @CRLF & _
"Last Name Madrid" & @CRLF & _
"Phone 4253068210" & @CRLF & _
"E-Mail Meli.madrid@yahoo.com" & @CRLF & _
"What is your age group? 19-39" & @CRLF & _
"Without my glasses and contacts-Farsightedness : I have trouble reading and seeing things up close yes" & @CRLF & _
"Without my glasses and contacts-Astigmatism : I have distorted vision and cannot see very well yes" & @CRLF & _
"What do you usually wear?-Glasses yes" & @CRLF & _
"What do you usually wear?-Contacts yes" & @CRLF & _
"What do you usually wear?-Reading Glasses yes" & @CRLF & _
"Do you have any of the following?-None of the above yes" & @CRLF & _
"I would like to see well at a distance without relying on glasses and contact lenses. 5" & @CRLF & _
"I would like to see well up close without relying on glasses and contact lenses. 5" & @CRLF & _
"Would your career or business activities improve if you were to become less dependent on glasses and contacts? Yes" & @CRLF & _
"Test Score -4.00" & @CRLF & _
"" & @CRLF & _
"The message has been sent from 107.77.205.32 (United States) at 2020-01-10 10:39:44 on iPhone unknown" & @CRLF & _
"Entry ID: 2190" & @CRLF & _
"Referrer: http://m.facebook.com" & @CRLF & _
"Form Host: https://www.nweyes.com/landing/smile/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")