# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\([^)]+,\s\d{4}(;\s[^)]+,\s\d{4})*\)"
test_str = ("(Palacios et al., 2014)\n"
"(Palacios et al., 2014)\n"
"(a nivel fisiológico/hormonal) en chicos y chicas y se dan en ritmos de desarrollo desigual (Pérez-Pérez y Navarro-Soria, 2012)\n"
"(Papalia et al., 2009)\n"
"(Martín et al., 2011)\n"
"(ciertas operaciones sobre las proposiciones: conjunción, disyunción…) y poner esta al servicio del recién adquirido pensamiento formal, pueden operar sobre las operaciones concretas, realizando así operaciones formales o de segundo orden (García-Madruga y Delval, 2010)\n"
"(García-Madruga y Delval, 2010)\n"
"(Pérez-Pérez y Navarro-Soria, 2012)\n"
"(Palacios et al., 2014)\n"
"(Martín et al., 2011)\n"
"(es la parte que tienen afectada las personas con trastorno de déficit de atención, TDA). También se encarga de la toma de decisiones, la planificación y la regulación de la propia conducta y por esto termina de desarrollarse en la adolescencia, cuando los sujetos adquieren la capacidad de pensar sobre el pensamiento y la conducta (Goldberg, 2004)\n"
"(Damasio, 2010)\n"
"(Toro, 2010)\n"
"(metaoperaciones). Podrán reflexionar sobre sí mismos y sobre diferentes realidades entre las posibles (García-Madruga y Delval, 2010)\n"
"(Elkind, 1978)\n"
"(ciberacoso, divulgación de información confidencial, acoso escolar…) y poco responsables (Mariscal et al., 2009)\n"
"(Mariscal et al., 2009)\n"
"(positiva o negativa) de su desarrollo y el bienestar con su nueva realidad (Palacios et al., 2014; Pérez-Pérez y Navarro-Soria, 2012)\n"
"(Duke et al., 1982)\n"
"(Palacios et al., 2014; Pérez y Navarro, 2012)\n"
"(Pérez-Pérez y Navarro-Soria, 2012)\n"
"(Martínez, 2010)\n"
"(Palacios et al., 2014; Pérez-Pérez y Navarro-Soria, 2012)\n"
"(Palacios et al., 2014; Pérez-Pérez y Navarro-Soria, 2012)\n"
"(Martín et al., 2011)\n"
"(Palacios et al., 2014)\n"
"(Palacios et al., 2014; Pérez-Pérez y Navarro-Soria, 2012)\n"
"(Martín et al., 2011)\n"
"(la adolescencia)\n"
"(Instagram, WhatsApp…) puede producir un sentimiento de aislamiento social (Martín et al., 2011)\n"
"(Oliva et al., 2002)\n"
"(Martín et al., 2011)\n"
"(ser compañeros), se hace necesaria la afinidad (Fuertes et al., 2001)\n"
"(afecto, apoyo…) que los chicos, tendrán redes sociales menos extensas que estos, cuyas necesidades suelen ser de logro o admiración (Martín et al., 2011)\n"
"(Palacios et al., 2014)\n"
"(Furman y Wehner, 1994)\n"
"(Palacios et al., 2014)\n"
"(figura 8), ya que el estilo de crianza que el adolescente ha experimentado configurará de manera decisiva la personalidad que se está formando (Palacios et al., 2014)\n"
"(Palacios et al., 2014)\n"
"(Palacios et al., 2014)\n"
"(Palacios et al., 2014)\n"
"(1936-…) propuso un modelo alternativo que diese cuenta de las diferencias de género y, tras su investigación con mujeres y niñas, encontró que, mientras que los varones estaban más interesados por el concepto abstracto de justicia, las mujeres se preocupaban más por las relaciones interpersonales y la responsabilidad a la hora de satisfacer las necesidades de los demás (Palacios et al., 2014)")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.