import Foundation
let pattern = #"^[^]*?`{3}(?:json)?\n(.*[^]*?)\n`{3}[^]*?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
```json
[
{
"questionType": "singleselect",
"shortDescription": "Who will own the Intellectual Property rights developed during the provision of services?",
"fullDescription": "According to the agreement, who will own the Intellectual Property rights developed during the provision of services?",
"options": [
"The Consultant",
"The Client",
"Both parties"
]
},
{
"questionType": "multipleselect",
"shortDescription": "What are included in Intellectual Property rights according to the agreement?",
"fullDescription": "What are included in Intellectual Property rights according to the agreement? (Select all that apply)",
"options": [
"Patents",
"Design",
"Trademark",
"Know-how",
"Trade secrets",
"Other"
]
},
{
"questionType": "textinput",
"shortDescription": "What rights does the Client have regarding the projects and products resulting from the services?",
"fullDescription": "What specific rights does the Client have regarding the projects and products resulting from the services?",
"options": []
}
]
```
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}