$re = '/^(?:[0-1])(?:[0-9])[0]+\z/';
$str = '180000000';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);