package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((\w{1,}\s*)*)$`)
var str = `tedtasd asdasdasd asdasd`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}