$re = '/(?x)
#http:\/\/.*|https:\/\/.*
https?.*/m';
$str = 'http://website.com
https://website2.com
htt://website3.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);